Polski | Română | Español


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cannot amend ini file direct and settings not saved :(
Author Message
BeLGaRaTh
New
*

Posts: 5
Joined: 2007 Jul
Status: Offline



Post: #1
Sad Cannot amend ini file direct and settings not saved :(
I just installed TCUP after finding when looking for plugins for TC. However I have a problem Sad Basically I am running windows vista, and I cannot get TCUP to remember any of its settings, eg tab positions etc like I can with TC (Configuration -> Save Position and Save Settings do nothing. Also If I try and amend the ini files by using Configuration -> Misc. It will not allow me to save the settigns and gives an error showing

Quote:---------------------------
<Error!>
---------------------------
Error: Cannot write C:\Program Files\TC UP\wincmd.ini!

Please remove the write protection!
---------------------------
OK
---------------------------

There is no protection on the file, I have also set TCUP to run as administrator with no change. I am the only user on the PC and have full admin rights.

Any ideas?
2007-07-11 01:46:26
Find all posts by this user Quote this message in a reply
m^2
Super Moderator
******

Posts: 401
Joined: 2006 Dec
Status: Offline



Post: #2
RE: Cannot amend ini file direct and settings not saved :(
BeLGaRaTh Wrote:I just installed TCUP after finding when looking for plugins for TC. However I have a problem Sad Basically I am running windows vista, and I cannot get TCUP to remember any of its settings, eg tab positions etc like I can with TC (Configuration -> Save Position and Save Settings do nothing. Also If I try and amend the ini files by using Configuration -> Misc. It will not allow me to save the settigns and gives an error showing

Quote:---------------------------
<Error!>
---------------------------
Error: Cannot write C:\Program Files\TC UP\wincmd.ini!

Please remove the write protection!
---------------------------
OK
---------------------------

There is no protection on the file, I have also set TCUP to run as administrator with no change. I am the only user on the PC and have full admin rights.

Any ideas?

Can you try to modify it while TCUP is running?

[Image: pcbsdec7.jpg]
2007-07-11 01:52:36
Visit this user's website Find all posts by this user Quote this message in a reply
BeLGaRaTh
New
*

Posts: 5
Joined: 2007 Jul
Status: Offline



Post: #3
RE: Cannot amend ini file direct and settings not saved :(
m^2 Wrote:Can you try to modify it while TCUP is running?

HeHe m^2 you get everywhere Smile

All the modifications I am trying to make are when TCUP is running Sad
2007-07-11 02:07:59
Find all posts by this user Quote this message in a reply
ULTIMA PRIME
Administrator
*******

Posts: 640
Joined: 2006 Nov
Status: Offline



Post: #4
RE: Cannot amend ini file direct and settings not saved :(
BeLGaRaTh Wrote:<Error!>
---------------------------
Error: Cannot write C:\Program Files\TC UP\wincmd.ini!

Please remove the write protection!
---------------------------
OK  
---------------------------

This is Windows Vista problem as i remember, no TC UP.

BeLGaRaTh Wrote:There is no protection on the file, I have also set TCUP to run as administrator with no change. I am the only user on the PC and have full admin rights.

I test TC UP in Windows Vista on same right once, and i have same problem.

Solution: You must add write rights to "wincmd.ini". I test this many times ago and i don't remember correctly how... but i think: wincmd.ini > right click > Properties > ...

Robert YouTube
Mario YouTube
2007-07-11 09:00:34
Visit this user's website Find all posts by this user Quote this message in a reply
bienchenmeier
New
*

Posts: 2
Joined: 2007 Jul
Status: Offline



Post: #5
RE: Cannot amend ini file direct and settings not saved :(
I have same problems, but i*m using WinXP. I've installed TC UP 2.8 with local-Admin-rights. The I startetd inereloc from ghisler.com to configure the position of the ini-file (Wincmd.ini and win_ftp.ini). For Example i set the directory for the ini-files to c:\data\ini for all users. After this I can find both inis in the directory c:\data\ini. But when i started tc up as a normal user, i can*t corrected the ini-settings, because tc up uses the inis in c:\program files\tcup. At this position i haven't any rights to correct settings und position.

bienchenmeier
2007-07-11 11:07:38
Find all posts by this user Quote this message in a reply
ULTIMA PRIME
Administrator
*******

Posts: 640
Joined: 2006 Nov
Status: Offline



Post: #6
RE: Cannot amend ini file direct and settings not saved :(
This is not same problem Smile

When you run Total Commander Ultima Prime on TC UP.exe (C:\Program Files\TC UP\TC UP.exe) - he AWAYS read configs from TC UP directory - reason this is i don't want modify orginal Total Commander settings (if he is instaled on user PC)

Run Total Commander Ultima Prime on TOTALCMD.EXE (C:\Program Files\TC UP\TOTALCMD.EXE) from TC UP directory - your configs should works

Robert YouTube
Mario YouTube
2007-07-11 11:37:51
Visit this user's website Find all posts by this user Quote this message in a reply
m^2
Super Moderator
******

Posts: 401
Joined: 2006 Dec
Status: Offline



Post: #7
RE: Cannot amend ini file direct and settings not saved :(
bienchenmeier Wrote:I have same problems, but i*m using WinXP. I've installed TC UP 2.8 with local-Admin-rights. The I startetd inereloc from ghisler.com to configure the position of the ini-file (Wincmd.ini and win_ftp.ini). For Example i set the directory for the ini-files to c:\data\ini for all users. After this I can find both inis in the directory c:\data\ini. But when i started tc up as a normal user, i can*t corrected the ini-settings, because tc up uses the inis in c:\program files\tcup. At this position i haven't any rights to correct settings und position.

bienchenmeier

To coexist with other (default) Total Commander's editions, TC UP ignores Total Commander's registry entry that sets ini location, that's why IniReloc doesn't work. But you can change it by specification of a new ini in it's command line. Just in a shortcut to TC UP write as a target
Code:
TCUP "/i=your path to wincmd.ini" "/f=your path to wcx_ftp.ini"
Or create a batch file with
Code:
start TCUP "/i=your path to wincmd.ini" "/f=your path to wcx_ftp.ini"

[Image: pcbsdec7.jpg]
2007-07-11 11:49:22
Visit this user's website Find all posts by this user Quote this message in a reply
[HUN]Peti
Super Hero + Crew Member
*****

Posts: 201
Joined: 2007 Apr
Status: Offline



Post: #8
RE: Cannot amend ini file direct and settings not saved :(
ULTIMA PRIME Wrote:Solution: You must add write rights to "wincmd.ini". I test this many times ago and i don't remember correctly how... but i think: wincmd.ini > right click > Properties > ...

Yes, and you can set User Account Contol off in Control Panel, this makes your Vista more comfortable but this way you lose that protection so viruses on Vista will be as powerful as on XP, Windows will allow them to write in Registry and use all other administrator rights, it's easier to install TC UP on a different drive which isn't protected by UAC.

[Image: selifest_admin.png]
[Image: selifest_wiki_auth.png]
2007-07-11 20:13:38
Visit this user's website Find all posts by this user Quote this message in a reply
BeLGaRaTh
New
*

Posts: 5
Joined: 2007 Jul
Status: Offline



Post: #9
RE: Cannot amend ini file direct and settings not saved :(
Thanks for the replies, I took ownership of the file as per Ultima Prime and it all seems to be working now. Great community, thanks again and also for making TC UP Cool
2007-07-11 20:24:20
Find all posts by this user Quote this message in a reply
hnoor0044
New
*

Posts: 1
Joined: 2016 Mar
Status: Offline



Post: #10
RE: Cannot amend ini file direct and settings not saved :(
I have also set TCUP to run as administrator with no change. I am the only user on the PC and have full admin rights.

== Solitaire ==
2016-03-14 12:16:04
Find all posts by this user Quote this message in a reply
Post Reply 




Contact Us | TC UP - Total Commander Ultima Prime | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication